Biggy Call Transcription experiencing issues

Incident Report for BigPanda

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 19:34 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 24, 2026 - 19:14 UTC

Monitoring

A fix has been deployed by our third-party vendor, and we are actively monitoring our Biggy services, with a focus on the Call Transcriptions service.

We will provide the next update in 30 minutes.
Posted Mar 24, 2026 - 19:12 UTC

Investigating

Due to an issue with a third-party vendor, customers might experience issues with Call Transcriptions.
We are checking with our vendor and will update this page with more information.
Posted Mar 24, 2026 - 16:23 UTC
This incident affected: Biggy Action Plans (Call Transcription).