Biggy Web Application UI - Degraded Performance

Incident Report for BigPanda

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 22:16 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 21:15 UTC

Investigating

Greetings,

Users may currently experience sluggish load times while navigating through pages in the Biggy Web Application UI.

Our R&D team is actively engaged and is investigating the issue.
Posted Apr 30, 2026 - 20:40 UTC
This incident affected: Biggy Services (Biggy Services).