Biggy Login

Incident Report for BigPanda

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 13:05 UTC

Update

SSO logins at https://app.biggy.io/login is currently redirecting users to a staging url. Other login methods are unaffected.
Our teams are engaged and a fix is being deployed.
Posted Jun 24, 2026 - 12:46 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 24, 2026 - 12:38 UTC
This incident affected: Biggy Services (Biggy Services).